Page 1 of 1

Strange behavior sync Simplenote

Posted: Wed Feb 28, 2018 1:14 pm
by awm
Hi there,

Two questions about sync with Simplenote:
1. Why doesn't the sync-date/time reflect the real date/time?
See Pic 1 attached: CN says: last synchronization 25-2-2016 14:19. In real life it is 28.2.2018 and I just synced !!
pic. 1.png
pic. 1.png (12.48 KiB) Viewed 38016 times

2. Sync is only working from Simple note to CN not the other way around? Why
See pic 2 for my sync settings
pic. 1.png
pic. 1.png (12.48 KiB) Viewed 38016 times


fyi:
- I run CN as Portable app
- notes in Simple note and in CN section do not have any attachments what so ever

Thanks.

Walter

Re: Strange behavior sync Simplenote

Posted: Wed Feb 28, 2018 3:26 pm
by gunars
Hi Walter

I just tried this myself with the current CN 3.11 (portable version) and it worked ok for me. I created a new note in Simplenote and synced it back to CN. It appeared and the last sync time was the current time. I then created a new note in CN and synced it back to Simplenote. It appeared there as expected. I then deleted both in CN and synced the change back to Simplenote, where they were also then deleted.

Two things:
1) When you say that changes in CN are not going back to Simplenote, are they in your NOTES section in CN. That is the only section you've configured to sync.
2) My proxy settings are set to "Disable proxy". That works for me, even with a complicated split-tunnel VPN on my work laptop.

Gunars

Re: Strange behavior sync Simplenote

Posted: Wed Feb 28, 2018 3:48 pm
by awm
Thanks.

Yeap they are in my NOTES section.
If I change to 'Disable proxy' then I get an error: Sync failed.

What's also strange is that in the status bar (where you see the sync status change while syncing; it says somethings like: "removing 23 notes from remote"(or something like that) but there are only 2 notes in Simpe Note!.....

But first: Why the strange date/time and no syncing to Simplenote?

Re: Strange behavior sync Simplenote

Posted: Thu Mar 01, 2018 4:23 am
by CintaNotes Developer
Hi awm,

This looks very much like a corruption of the internal sync bookkeeping.
Could you please try creating a new notebook and syncing it with the same SN account. Will it exhibit the same weird behavior?

Re: Strange behavior sync Simplenote

Posted: Fri Mar 02, 2018 10:25 am
by awm
OK.
I made a new (emtpy) test notebook.
I made a new test note in CN (testnote1 CN->SN; Upload)
I emptied SN (also trash bin) and made a testnote 2 SN -> CN (download)

Sync settings not changed (see above post).

Result after syncing:
2018-03-02_112049.png
2018-03-02_112049.png (7.31 KiB) Viewed 37964 times


Download (SN -CN) works fine
Upload (CN->SN) doesn't work
Status bar message: Not synchronized; Synchronization not finished try again later

Re: Strange behavior sync Simplenote

Posted: Mon Mar 05, 2018 9:14 am
by CintaNotes Developer
Well that's already something. Could you please collect and send to me to support@ the log of the sync process? Thanks!

Re: Strange behavior sync Simplenote

Posted: Mon Mar 05, 2018 11:16 am
by awm
mmm. Where do I find the logfile?
I run CN Portable

Re: Strange behavior sync Simplenote

Posted: Tue Mar 06, 2018 5:07 am
by CintaNotes Developer
First you need to activate logging in Help/Debug.
Then CN will restart. Start sync. After failure, exit cN and find the latest log.N.txt file near cintanotes.exe.
This will be the needed file. Thanks!

Re: Strange behavior sync Simplenote

Posted: Tue Mar 06, 2018 7:43 am
by awm
Thanks
But why do I get an error message while attaching the file to this reply.
It says: Invalid file extension.....

Re: Strange behavior sync Simplenote

Posted: Tue Mar 06, 2018 9:07 am
by CintaNotes Developer
Forum has some arcane restrictions on attached file extensions. I'll take a look what's wrong there.
Meanwhile you can simply send the file to me to support@cintanotes.com

Re: Strange behavior sync Simplenote

Posted: Tue Mar 06, 2018 10:19 am
by awm
just did this

Thanks