Page 1 of 1

Notes not saving

Posted: Wed Apr 05, 2023 9:23 am
by GaryF
Recently my notes stopped saving. Each time I tried I got an error saying 'Runtime error'.
I've downloaded the latest version and imported and updated the databases but still the same thing happening.
Anyone can guess at what's going on please? I can't lose this I have years and years of notes in there.
PS: I run two separate portable versions and have done for years. 1 is working perfectly, the other gives the runtime error whenever I save something.

Re: Notes not saving

Posted: Wed Apr 05, 2023 11:07 pm
by GaryF
I fixed this. I exported all sections individually as xml files, then deleted all the old databases. Then imported all xml files back into a brand new database. Obviously the database must have corrupted for some reason.

Re: Notes not saving

Posted: Tue Apr 11, 2023 1:48 pm
by CintaNotes Developer
Hi and sorry for late reply!
Great that you managed to fix the problem yourself!
Indeed sometimes the notes database files can get corrupted and this happens.
To prevent corruption, I recommend to open cintanotes.settings file and set sqlite.pragma.synchronous = FULL.
It will make CN a bit slower, but the likelihood of file corruption will be greatly reduced.