Question about used Ctrl+F12 from webpages by IE

blueforster
Posts: 5
Joined: Wed Feb 20, 2013 6:39 am
Contact:

Question about used Ctrl+F12 from webpages by IE

Postby blueforster » Wed Feb 20, 2013 7:22 am

When used Ctrl+F12 for the selected content of the webpages by IE browser, no content and no link be added to the note.
Any one know how to fix it? Or the free version could not clip content from IE browser?
User avatar
CintaNotes Developer
Site Admin
Posts: 4740
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby CintaNotes Developer » Wed Feb 20, 2013 9:59 am

Hi!
Which version of IE are you using?
Alex
blueforster
Posts: 5
Joined: Wed Feb 20, 2013 6:39 am
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby blueforster » Thu Feb 21, 2013 2:58 am

The IE 8, other machine with the same IE 8 version also has the same question.
If the selection was the web page content, no content and no link to the note after pressed Ctrl+F12,
only the html title could be on the note title.
And after swith the title setting to the first line, no title and no content be clipped by Ctrl+F12.
User avatar
CintaNotes Developer
Site Admin
Posts: 4740
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby CintaNotes Developer » Thu Feb 21, 2013 9:56 am

Thanks for the info!
Could you please activate the Help/Debug/Debug logging mode and try to clip again?
After that CintaNotes will generate the log file called "log.1.txt".
Please send it to me to support@cintanotes.com

Thanks!
Alex
blueforster
Posts: 5
Joined: Wed Feb 20, 2013 6:39 am
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby blueforster » Thu Feb 21, 2013 10:48 am

Thanks your help, it is amazing, when I active the Help/Debug mode, the issue fixed,
the webpage content and link could be clipped by Ctrl+F12.
Then de-actived the Debug mode, the issue was not happened.
User avatar
CintaNotes Developer
Site Admin
Posts: 4740
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby CintaNotes Developer » Fri Feb 22, 2013 8:56 am

blueforster wrote:Thanks your help, it is amazing, when I active the Help/Debug mode, the issue fixed,
the webpage content and link could be clipped by Ctrl+F12.
Then de-actived the Debug mode, the issue was not happened.


OK so this seems to be a timing issue. IE doesn't manage to put the data into clipboard in the timeframe of 1 second which CN is waiting.
Please do the following:
1) Replace your cintanotes.exe file with the one below
2) Open cintanotes.settings (which is either near cintanotes.exe or in %appdata%/cintanotes) and add the following line to the end:

Code: Select all

clipping.waittime.seconds = 3

3) Deactivate debug logging mode and try clipping again.

Please let me know if this helps! Thanks
Attachments
CintaNotes_with_configurable_clip_timing.zip
(2.12 MiB) Downloaded 389 times
Alex
blueforster
Posts: 5
Joined: Wed Feb 20, 2013 6:39 am
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby blueforster » Fri Feb 22, 2013 10:15 am

The file and the setting are not useful for web content clipping. And even I use the debug way again, the issue could not be fixed.
The web content and link could not be clipped by Ctrl+F12 again.
User avatar
CintaNotes Developer
Site Admin
Posts: 4740
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby CintaNotes Developer » Fri Feb 22, 2013 10:25 am

Thanks for the info. Could you please tell, which version of Windows do you have?
Also please send the log file.
Alex
blueforster
Posts: 5
Joined: Wed Feb 20, 2013 6:39 am
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby blueforster » Fri Feb 22, 2013 11:29 am

The Windows version is 7 32bit.
I re-installed the 2.0.3 version, the attachment is the log to record used Ctrl+F12, but no content and no link be clipped.
Attachments
log.4.zip
(18.03 KiB) Downloaded 243 times
Thomas Lohrum
Posts: 1312
Joined: Tue Mar 08, 2011 11:15 am

Re: Question about used Ctrl+F12 from webpages by IE

Postby Thomas Lohrum » Fri Feb 22, 2013 1:35 pm

Alex,

i reported problems with clipping quite a while ago. I use Win7 64-Bit with Firefox. Occasionally a blank note gets created. No clipped text, no link gets added. The other time its fine though.

Thomas
User avatar
CintaNotes Developer
Site Admin
Posts: 4740
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby CintaNotes Developer » Fri Feb 22, 2013 4:01 pm

blueforster wrote:The Windows version is 7 32bit.
I re-installed the 2.0.3 version, the attachment is the log to record used Ctrl+F12, but no content and no link be clipped.


Thanks for the logs.
Seems that the "Ctrl+C" doesn't get passed to IE. This can happen if IE is running with admin privileges and CN is not. Is this the case?
Alex
gunars
Posts: 202
Joined: Fri Nov 08, 2013 5:35 am
Contact:

Re: Question about used Ctrl+F12 from webpages by IE

Postby gunars » Tue Jan 14, 2014 9:08 am

Thomas Lohrum wrote:Alex,

i reported problems with clipping quite a while ago. I use Win7 64-Bit with Firefox. Occasionally a blank note gets created. No clipped text, no link gets added. The other time its fine though.

Thomas

I've run into this a number of times myself, also Firefox on Win7/64. At first I thought there might be some odd code on the webpage, but with the same selection that produced a blank in CN, the text was successfully saved in Surfulater. One workaround appears to be to select the text you want and then doing a Ctrl-C copy before clipping to CN. This is still better than just a paste into a new note since it will also fill in the Link field.

Return to “Bug Reports”