Automatic Backups not Working

User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Automatic Backups not Working

Postby usbpoweredfridge » Sat Jan 25, 2014 2:13 pm

For the last few stable versions (I can't recall now when the problem started exactly, but it has been present for a little while), the automatic backup feature of CintaNotes does not work for me. All the backup options are enabled - hourly, daily, weekly - but none actually trigger, no matter how long I leave the database open for. From cintanotes.settings:

Code: Select all

backup.checkperiod.minutes = 5
backup.daily.enabled = 1
backup.folder = backup
backup.hourly.enabled = 1
backup.weekly.enabled = 1


If I go into the menu and click Backup Now, a single backuo file is created for the currently open database (it is not named hourly, daily, or weekly - a timestamp just gets placed at the end of the database name). That is the only way the backups work for me however.
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Fri Jan 31, 2014 6:49 am

Hi and thanks for the report!

Could you please tell where your CintaNotes folder is located, and where you're looking for backup files?
Thanks!
Alex
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Fri Jan 31, 2014 7:46 am

I think I've found the reason of the problem.
Please try the following fixed version:
Attachments
CintaNotes_251_b1_2.zip
(2.05 MiB) Downloaded 201 times
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Fri Jan 31, 2014 11:46 am

Thanks, I will give it a try and report back. One thing I didn't mention (I didn't think it was important) was that a few stable versions ago, I enabled one of the backup options (only two of the three were enabled, I think it might have been 'weekly' that was not ticked), and despite having a tick beside it in the CintaNotes file menu, the option itself in cintanotes.settings was still set to zero. So, I used a text editor to set it to '1'. I was going to report it at the time, but I have too many forum logons already, and was reluctant to create another one.
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Fri Jan 31, 2014 12:04 pm

Ok, sadly nothing has changed. Replaced the .exe from the one in the download, opened CintaNotes, left it open for about 10 minutes, and then checked the backup folder (which is in C:\Users\{username}\AppData\Roaming\CintaNotes\backup\). No new backups created. The last is the one I created back on 26 January by using the 'backup now' option when I started this thread initially. Oh, and the CintaNotes installation folder is in C:\Program Files (x86)\CintaNotes (profile folder as mentioned is in Roaming).
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Fri Jan 31, 2014 2:04 pm

Ok could you please do the same, only this time with debug logging active (Help/Debug Log).
This will create the log.1.txt file in the %APPDATA%/CintaNotes folder.
Please mind that backup should start 5 minutes after program start.
Alex
gunars
Posts: 187
Joined: Fri Nov 08, 2013 5:35 am
Contact:

Re: Automatic Backups not Working

Postby gunars » Fri Jan 31, 2014 2:51 pm

usbpoweredfridge wrote:Thanks, I will give it a try and report back. One thing I didn't mention (I didn't think it was important) was that a few stable versions ago, I enabled one of the backup options (only two of the three were enabled, I think it might have been 'weekly' that was not ticked), and despite having a tick beside it in the CintaNotes file menu, the option itself in cintanotes.settings was still set to zero. So, I used a text editor to set it to '1'. I was going to report it at the time, but I have too many forum logons already, and was reluctant to create another one.

I ran into that also, but that's expected behaviour. See Alex's explanation here: viewtopic.php?f=6&t=1781
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Sat Feb 01, 2014 12:53 am

@Alex: Sure, here is the log file:
https://dl.dropboxusercontent.com/u/105555957/log.1.zip

@gunars: Ah, that explains it - thanks.
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Mon Feb 03, 2014 11:07 am

[quote="usbpoweredfridge"]@Alex: Sure, here is the log file:
https://dl.dropboxusercontent.com/u/105555957/log.1.zip

Thanks a lot for the log file! I'll investigate it and get back to you with the results.
Alex
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Tue Feb 04, 2014 11:53 am

In the log I see the following:
"Set backup checking to start in 125 minutes".

Are you sure you still have "backup.checkperiod.minutes = 5" in the settings file?
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Wed Feb 05, 2014 8:45 am

Yes - just checked, and the settings file is still set to 5 minutes. So, I guess the question is why is the settings file being ignored, how did my three databases get set to 125 minutes, and how do I revert those databases to 5 minutes?
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Wed Feb 05, 2014 9:48 am

The time setting is not per DB, it remained in the settings file. Only "hourly/daily/weekly"-enabledness moved to DB.

Could you please try this version here: <file deleted, see below>
Alex
gunars
Posts: 187
Joined: Fri Nov 08, 2013 5:35 am
Contact:

Re: Automatic Backups not Working

Postby gunars » Wed Feb 05, 2014 5:01 pm

Out of curiosity, I tried this version (251_b1_3), but got an error: The program can't start because enigma_ide.dll is missing from your computer. Try reinstalling the program to fix this problem.

The 251_b1_2 version runs ok.
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Thu Feb 06, 2014 5:27 am

Same error as gunars - Enigma is the copy protection I assume?

(If the backup time is not stored in the database, that means my databases are still intact, which is something that worried me)
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Thu Feb 06, 2014 5:38 am

Yes, sorry, was in a hurry and forgot to protect the exe. Thanks for pointing this out.
Here is the correct version:
Attachments
CintaNotes_251_b1_4.zip
(2.04 MiB) Downloaded 265 times
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Thu Feb 06, 2014 8:18 am

Yes, the backup seems to work now. I ran CN, waited 5 minutes, and checked the backup folder, and there was a new backup created. I then opened the file menu, switched to my second database, waited a few minutes, and it too had a backup generated (ditto for the third database).

Edit: Hm, something still seems to be wrong. I have three DB's:
Interesting Links.db
cintanotes.db
Deleted Programs.db

The backups that were created were:
Deleted Programs.weekly.db
Deleted Programs.daily.db
cintanotes.daily.db
cintanotes.hourly.db
Interesting Links.daily.db
Interesting Links.hourly.db

Then, I closed CN and opened it again. Then, Interesting Links.weekly.db was created. So:
i. Why in the first instance was daily+hourly created for two of the DB's, but daily+weekly for the other DB?
ii. When I opened CN the second time, why was a .weekly created for the open DB? Shouldn't .weekly be created at the same time as .daily and .hourly, and shouldn't .daily and .hourly be overwritten with a new backup as well?
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Thu Feb 06, 2014 9:20 am

Producing a backup takes time, since it is done in the background requiring as little CPU/disk resources as possible.
The intent is to make the backup process very transparent.
So maybe the weekly backup wasn't created because you didn't wait long enough?
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Thu Feb 06, 2014 9:39 am

How long do I have to wait? If the settings file says 5 minutes, I expect that it will be 5 minutes - and I waited longer than that (none of my DB files are very large, and CN obviously had no problems in creating some of the backups - but it would happily do hourly and daily backups which are exactly the same size as the weekly). I still don't think the backup function is working properly to be honest.
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Automatic Backups not Working

Postby CintaNotes Developer » Thu Feb 06, 2014 9:51 am

usbpoweredfridge wrote:How long do I have to wait? If the settings file says 5 minutes, I expect that it will be 5 minutes - and I waited longer than that (none of my DB files are very large, and CN obviously had no problems in creating some of the backups - but it would happily do hourly and daily backups which are exactly the same size as the weekly). I still don't think the backup function is working properly to be honest.


Ok, creating one backup file should definitely be under 5 minutes.

Are you sure that all your DBs have same backup settings? Have you checked in the File/Backup submenu?
Also a "daily" backup is overwritten when the day in current date is different from the day of the "daily" file's last modification date.
The same goes for hourly and weekly, only with one hour and one week as units.
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Automatic Backups not Working

Postby usbpoweredfridge » Fri Feb 07, 2014 9:17 am

Just opened all three DB's, and checked - and yes, all three have Daily, Hourly and Weekly checked (it seems to me that having made this a per DB setting has complicated things un-necessarily but that's the way DN has been designed and I guess there is no way back). I'm still just not seeing any real logic in how CN creates a Hourly+Daily for two DB's, but then when I switch to the third DB, created an Daily+Weekly for it (and skipped Hourly entirely). All I really have is the feeling that it is not working correctly.

At this point in time, I think the best thing for me to do is to disable the CN backup entirely, and just rely on an external backup program to backup the DB's.

Return to “Bug Reports”