[solved] Simplenote Special Character Syncing error

ns6uey
Posts: 2
Joined: Sun Dec 14, 2014 1:22 am
Contact:

[solved] Simplenote Special Character Syncing error

Postby ns6uey » Sun Dec 14, 2014 1:45 am

# My PC Environment #
Windows 8.1 Industry
Cintanotes 2.8.3
===============

I am Korean and I use Korean Language.

Syncing Simplenote and CintaNotes, Some spacial characters (e.g. '<', '>', '&', and others may also) have error.
Those Characters have no error when they are in English Sentences, but in Korean Senteces, they became '&lt;', '&gt;', '&amp;', ...

I use CintaNotes on PC, but I use Simplenote on Android.

Please Fix it and Let me use special characters with Korean Language.

Thank you




that test messege is

Title
"I want < and > on Simplenote"

Text
"No lt and gt!

한글이랑 같이 쓰면 >>> 이렇게 깨져나온다
이것 말고 다른_특수문자는-과연&어떻게@나올까 "

Tags
"과연>태그는>어떨까 "
Attachments
cintanotes error.png
cintanotes error.png (72.47 KiB) Viewed 2715 times
Last edited by ns6uey on Wed Dec 17, 2014 7:27 pm, edited 1 time in total.
User avatar
CintaNotes Developer
Site Admin
Posts: 4747
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Simplenote Special Character Syncing error

Postby CintaNotes Developer » Mon Dec 15, 2014 8:24 am

Hello ns6uey,

First of all, thanks a lot for your message, and of course for byuing the Lifetime license!

Turning of ">" and "&" to their HTML encoded versions is actually a feature of CintaNotes and not a bug.
It enables it to seamlessly trasfer all text formatting across Simplenote sync, even the formatting that Simplenote doesn't support.

To fix the display of this note in Simplenote, please do the following in the Simplenote web interface: press the button with the "ⓘ" icon, and then check "Markdown formatting" checkbox.

Please let me know if this helps!

UPD: it would be great if one could set it as SN account option, but it seems it's not supported by SN at the moment:
http://help.simplenote.com/customer/por ... as-default
So unfortunately you'll have to do it for each note with such symbols that you want to view in the browser.
Alex
ns6uey
Posts: 2
Joined: Sun Dec 14, 2014 1:22 am
Contact:

Re: [solved] Simplenote Special Character Syncing error

Postby ns6uey » Wed Dec 17, 2014 7:35 pm

Thanks for your reply, alex.

Just for now, I understood your solution.
and I believe you will make this better someday next version.

Have a good day! :)
User avatar
CintaNotes Developer
Site Admin
Posts: 4747
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: [solved] Simplenote Special Character Syncing error

Postby CintaNotes Developer » Thu Dec 18, 2014 12:22 pm

Thanks for your understanding, ns6uey!
Alex

Return to “Bug Reports”