Page 1 of 1

[solved] Simplenote Special Character Syncing error

Posted: Sun Dec 14, 2014 1:45 am
by ns6uey
# My PC Environment #
Windows 8.1 Industry
Cintanotes 2.8.3

I am Korean and I use Korean Language.

Syncing Simplenote and CintaNotes, Some spacial characters (e.g. '<', '>', '&', and others may also) have error.
Those Characters have no error when they are in English Sentences, but in Korean Senteces, they became '&lt;', '&gt;', '&amp;', ...

I use CintaNotes on PC, but I use Simplenote on Android.

Please Fix it and Let me use special characters with Korean Language.

Thank you

that test messege is

"I want < and > on Simplenote"

"No lt and gt!

한글이랑 같이 쓰면 >>> 이렇게 깨져나온다
이것 말고 다른_특수문자는-과연&어떻게@나올까 "

"과연>태그는>어떨까 "

Re: Simplenote Special Character Syncing error

Posted: Mon Dec 15, 2014 8:24 am
by CintaNotes Developer
Hello ns6uey,

First of all, thanks a lot for your message, and of course for byuing the Lifetime license!

Turning of ">" and "&" to their HTML encoded versions is actually a feature of CintaNotes and not a bug.
It enables it to seamlessly trasfer all text formatting across Simplenote sync, even the formatting that Simplenote doesn't support.

To fix the display of this note in Simplenote, please do the following in the Simplenote web interface: press the button with the "ⓘ" icon, and then check "Markdown formatting" checkbox.

Please let me know if this helps!

UPD: it would be great if one could set it as SN account option, but it seems it's not supported by SN at the moment: ... as-default
So unfortunately you'll have to do it for each note with such symbols that you want to view in the browser.

Re: [solved] Simplenote Special Character Syncing error

Posted: Wed Dec 17, 2014 7:35 pm
by ns6uey
Thanks for your reply, alex.

Just for now, I understood your solution.
and I believe you will make this better someday next version.

Have a good day! :)

Re: [solved] Simplenote Special Character Syncing error

Posted: Thu Dec 18, 2014 12:22 pm
by CintaNotes Developer
Thanks for your understanding, ns6uey!