XML and focus-losing bugs

mcl

XML and focus-losing bugs

Postby mcl » Tue Nov 03, 2009 10:15 pm

Hi. I use CintaNotes everyday, because it's best note manager I ever seen.
I found few problems — not so big, but very distressing.
It would be nice, if you find them fix-worthy.

CN can't import non-UTF16 XML files.
Not a bug at all, but i hope, CN become UTF8-compatible too.
Also importing XML with missed fields causes importing empty notes.
I think, missed field can be set by default (empty, current date/time).

Another bugs appears when CN didn't return focus, i guess.
WinXP SP2, CN Beta M10.5.

Steps to reproduce:
1. Open any application (ex. browser);
2. Open CN window;
3. Hide CN window using taskbar button. Application window still unfocused;
4.1. Pressing hot-key to clip text often causes error message:
class err::RuntimeException
Failed to attach thread input
4.2.a. Click application taskbar button to activate it;
4.2.b. Press hot-key to insert new note. In my case, "New Note" window will be hidden.

I think my description still too clumsy to understand.
User avatar
CintaNotes Developer
Site Admin
Posts: 4654
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: XML and focus-losing bugs

Postby CintaNotes Developer » Wed Nov 04, 2009 6:28 pm

Hello mcl and many thanks for reporting!
As for non-UTF8 XML files, I'm aware of that and intended to change the XML reading engine anyway - now its UCS-2 only.

For the "Failed to attach input" error, I could reproduce it and will try to see what is happening there..

Thanks again!
Alex

Return to “Bug Reports”