3.2 Postcondition failed when deleting note

Thomas Lohrum
Posts: 1310
Joined: Tue Mar 08, 2011 11:15 am

3.2 Postcondition failed when deleting note

Postby Thomas Lohrum » Sat Jul 30, 2016 12:13 am

When i delete a note from inside the editor (Ctrl+Del) i get the following error:

---------------------------
[Error]
---------------------------
class err::LogicException
Postcondition failed:
app::model::data::NoteMapper::getNote
n
---------------------------
OK
---------------------------

Thomas
User avatar
Ovg
Posts: 126
Joined: Mon Feb 02, 2015 8:44 am
Contact:

Re: 3.2 Postcondition failed when deleting note

Postby Ovg » Sat Jul 30, 2016 5:40 am

I can confirm this ussue. BTW note has been removed ...
It's impossible to lead us astray for we don't care even to choose the way.
CN 3.11 LifeTime Pro Licence / Windows 7 SP1 x64
User avatar
CintaNotes Developer
Site Admin
Posts: 4708
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: 3.2 Postcondition failed when deleting note

Postby CintaNotes Developer » Sat Jul 30, 2016 5:51 am

Hi Thomas,

I confirm that issue. Sorry for that. Will fix it asap.
Alex
date
Posts: 243
Joined: Sat Aug 01, 2015 5:15 am
Contact:

Re: 3.2 Postcondition failed when deleting note

Postby date » Sat Jul 30, 2016 7:54 am

Ovg wrote:I can confirm this ussue. BTW note has been removed ...
The note is removed, but not closed. When you close the note with Esc, the note returns again.
As a workaround, today I'm tagging them with a 'delete' tag. Pretty inconvenient still, especially if you're setting up some rules and don't really want the previous version.
User avatar
Ovg
Posts: 126
Joined: Mon Feb 02, 2015 8:44 am
Contact:

Re: 3.2 Postcondition failed when deleting note

Postby Ovg » Sat Jul 30, 2016 10:56 am

2date

Can't confirm. When I close the note with Esc/Cancel, the note disapeares ...
It's impossible to lead us astray for we don't care even to choose the way.
CN 3.11 LifeTime Pro Licence / Windows 7 SP1 x64
date
Posts: 243
Joined: Sat Aug 01, 2015 5:15 am
Contact:

Re: 3.2 Postcondition failed when deleting note

Postby date » Sat Jul 30, 2016 12:47 pm

Ovg wrote:2date

Can't confirm. When I close the note with Esc/Cancel, the note disapeares ...

Depends on the 'Save on Esc' setting, it seems. Cancel always works though.

Not to worry, I can work around it, and he will fix it 'asap,' I can live with it for a while ;)
Thomas Lohrum
Posts: 1310
Joined: Tue Mar 08, 2011 11:15 am

Re: 3.2 Postcondition failed when deleting note

Postby Thomas Lohrum » Thu Aug 18, 2016 11:07 am

Confirm fixed with 3.2.1

Thomas

Return to “Bug Reports”