Some rules have stopped working

SamLowry
Posts: 3
Joined: Tue Sep 19, 2017 1:32 pm
Contact:

Some rules have stopped working

Postby SamLowry » Tue Sep 19, 2017 1:54 pm

I upgraded to CintaNotes 3.10.

Now, although some longstanding rules work, others don't.

eg:-

This fails now: "if text contains '@bk' --- add tag(s) '@/@book'"
This fails now: "if any text field contains '@ac --- move to section 'Research'
This still works: "if any text field contains 'Nowz' --- move to section 'nowz'"

The first two were created a year or so ago; the last, a couple of months ago.

It doesn't seem to matter what program I'm clipping from.

I then downgraded to CintaNotes 3.9.1. All rules now work.

Thanks for an excellent program. I'm very dependent on CintaNotes. Any light on the issue above would be appreciated.
User avatar
CintaNotes Developer
Site Admin
Posts: 4745
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Some rules have stopped working

Postby CintaNotes Developer » Wed Sep 20, 2017 11:51 am

Hello Sam,

Thanks a lot for your report!
Do I understand correctly that only rules that have the "@" symbol in conditions have stopped working?
Alex
SamLowry
Posts: 3
Joined: Tue Sep 19, 2017 1:32 pm
Contact:

Re: Some rules have stopped working

Postby SamLowry » Wed Sep 20, 2017 10:39 pm

Yep, the rules that fail contain the "@" in their conditions.

I have 15 active rules. Only a few don't involve the @ sign. They work fine. The "nowz" one as detailed above. And also one with text containing "(({".
User avatar
CintaNotes Developer
Site Admin
Posts: 4745
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Some rules have stopped working

Postby CintaNotes Developer » Thu Sep 21, 2017 1:51 pm

Thanks for the info. I'm already on it. Will let you know as soon as there's a fix.
Alex
User avatar
CintaNotes Developer
Site Admin
Posts: 4745
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Some rules have stopped working

Postby CintaNotes Developer » Tue Oct 03, 2017 11:02 am

Hi Sam,

Could you please try this version, it should fix the issue:
http://cintanotes.com/files/debug/Cinta ... _Beta1.zip

Thanks!
Alex
SamLowry
Posts: 3
Joined: Tue Sep 19, 2017 1:32 pm
Contact:

Re: Some rules have stopped working

Postby SamLowry » Tue Oct 03, 2017 5:07 pm

Great: CintaNotes 3.11 beta 1 works fine with my @ rules.

Thanks, Alex. Your work is very much appreciated here.

All the best,

SL
User avatar
CintaNotes Developer
Site Admin
Posts: 4745
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Some rules have stopped working

Postby CintaNotes Developer » Wed Oct 04, 2017 8:10 am

Great, thanks to you for help and patience!
Alex

Return to “Bug Reports”