Focus in Tabs instead of Title after clipping

Clairvaux
Posts: 53
Joined: Sun Dec 25, 2016 12:43 pm
Contact:

Focus in Tabs instead of Title after clipping

Postby Clairvaux » Thu Oct 05, 2017 11:53 am

I just noticed that after clipping a note, focus is now in the Tab field instead of the Title field.

I'm pretty sure it was in the Title field before. Options / Editor / Initial Focus = Title.

Also, just experienced a crash after attempting to change an option.

Clipping from Firefox v.55.0.3 64-bit. CN v.3.10 portable, Windows 7 64-bit.
User avatar
CintaNotes Developer
Site Admin
Posts: 4717
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Focus in Tabs instead of Title after clipping

Postby CintaNotes Developer » Tue Oct 10, 2017 10:06 am

Actually after clipping focus is always in the Tags field (CN assumes you want to tag note after it's been clipped).
The "initial focus" setting applies only to cases when you create a new note or edit a note from within CN.
Alex
User avatar
CintaNotes Developer
Site Admin
Posts: 4717
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Focus in Tabs instead of Title after clipping

Postby CintaNotes Developer » Tue Oct 10, 2017 10:08 am

About crash - probably this was one of "snap window to screen edge" options.
I've already got another report of this crash, however we need to be able to reproduce it.
Do you have a high-DPI screen? And what is your font scaling setting in Windows?
Alex
Clairvaux
Posts: 53
Joined: Sun Dec 25, 2016 12:43 pm
Contact:

Re: Focus in Tabs instead of Title after clipping

Postby Clairvaux » Tue Oct 10, 2017 12:24 pm

CintaNotes Developer wrote:Actually after clipping focus is always in the Tags field (CN assumes you want to tag note after it's been clipped).
The "initial focus" setting applies only to cases when you create a new note or edit a note from within CN.

Incredible ! I could have bet it was in the title -- and the Initial Focus option is misleading.

Tagging a note after clipping makes sense. However, my personal experience, after clipping an article from Firefox, is I need to adjust the title : most of the time the title is correct, however I have a personal format where I append to it a) the name of the site (most of the time it gets clipped into the title as well, but not always), b) the date the article has been published, which is necessary because CN only records the creation and modification date of the note -- which is often different from the publication date of the clipped article, if only by a day.

I could be satisfied with the publication date being clipped from the Web page into the main text, but sometimes the article is several years old, so I feel this is a major identification item for the note.

CintaNotes Developer wrote:Do you have a high-DPI screen? And what is your font scaling setting in Windows?

Not really, but my setup is indeed intolerant of non high DPI-aware software -- such as CN ! ;) The high-DPI problems are very limited in CN, once I've checked Disable Display Scaling on High DPI Settings in the Properties / Compatibility tab of the executable : some parts of the GUI are cropped out of their frame in the note export process.

I have a 1920 x 1200 screen, Windows 7 64-bit, and my custom DPI is set in Windows at 150 %, with the box Use Windows XP Style DPI Scaling = No.
User avatar
CintaNotes Developer
Site Admin
Posts: 4717
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Focus in Tabs instead of Title after clipping

Postby CintaNotes Developer » Wed Oct 11, 2017 4:48 am

Clairvaux wrote:Incredible ! I could have bet it was in the title -- and the Initial Focus option is misleading.

Well I agree that the discrepancy is causing confusion and probably we'll get rid of it with the new UI.

Not really, but my setup is indeed intolerant of non high DPI-aware software -- such as CN ! ;) The high-DPI problems are very limited in CN, once I've checked Disable Display Scaling on High DPI Settings in the Properties / Compatibility tab of the executable : some parts of the GUI are cropped out of their frame in the note export process.
I have a 1920 x 1200 screen, Windows 7 64-bit, and my custom DPI is set in Windows at 150 %, with the box Use Windows XP Style DPI Scaling = No.


Ok thanks for the details, I will try the high-DPI setting and see if the crash could be repeated.
Alex

Return to “Bug Reports”