Search not Finding Characters that are in a Note

User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Thu Nov 27, 2014 7:50 am

Continuing my problematic attempts to capture articles from DuffelBlog (viewtopic.php?f=6&t=1928), I am now having a problem with the CN search feature. As noted in that other thread, when I capture articles from this website, some characters are replaced by > signs. To try and find these (so I can correct them), I type > into the search field. However, no matches are found (search is set to 'text only'). The trouble is - I know there are matches, because I have one sitting right in front of me. CN just refuses to match the > character though.

I thought it may have been some weird unicode thing (like " or ' have a slightly different unicode equivalent which requires you to use the correct one), but even copying the > from the note and pasting it into the search field does not work.

Chris
Thomas Lohrum
Posts: 1316
Joined: Tue Mar 08, 2011 11:15 am

Re: Search not Finding Characters that are in a Note

Postby Thomas Lohrum » Thu Nov 27, 2014 7:56 am

Chris,

i can not tell what is going on with your pasted data. For me it is working. I can search for ">" inside notes, which i have created/edited myself.

Thomas
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Fri Nov 28, 2014 8:08 am

Thanks Thomas. I have found out something else - if I create a new note (Insert), and type in > and then try the search, it works fine. The problem only occurs when I clip from DuffelBlog and then try and find the > character. So for example, go here:
http://www.duffelblog.com/2014/11/bill- ... apr-video/

Highlight the heading, right down to the end sentence. Clip it. The clipped note should have a > in it somewhere where a URL was meant to go. If so, click Ok to accept the note, and then try and find the > character via the search - you won't be able to do it.

Chris
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Tue Mar 10, 2015 10:00 am

Just found another instance of this. I have a DB with a number of notes in it. I clicked in the search field (set to 'text only') and typed in the word 'comment'. CN found a number of matches. Later on, I was randomly scrolling through the DB, and stumbled across a note that had the word comment in it, but which is not found by the search. Even copying and pasting the 'comment' from the note into the search field does not find the note.

Chris
User avatar
CintaNotes Developer
Site Admin
Posts: 4748
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby CintaNotes Developer » Tue Mar 10, 2015 5:32 pm

Hi Chris,
thanks for reporting!
It would really help to have the notebook, or at least part of it.

Maybe you could make a copy, delete all notes but the problematic ones from it, and send to support@cintanotes.com?
Thanks in advance!
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Wed Mar 11, 2015 7:34 am

Sample DB attached to this post. I tested that it fails with the search before I added it - I set the search field to 'text only' and typed in 'comm' and it didn't find the 'comment' in the note.

Chris
Attachments
ZTest.zip
(4.05 KiB) Downloaded 340 times
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Wed Mar 11, 2015 11:32 am

There is a CN setting that fixes this, "Search Inside Words". Well, the problem with the word 'comment' anyway, I no longer have any of the notes with the '>' in them that I reported as the original problem (so I can't check if that option fixes those as well, it may very well do).

Chris
User avatar
CintaNotes Developer
Site Admin
Posts: 4748
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby CintaNotes Developer » Wed Mar 11, 2015 3:27 pm

Hi Chris,
Indeed, with "Search inside words", CintaNotes searches only for matches on word boundaries.
A change in case is not considered to be a word boundary, that's why "comment" in "wentComment" is not found.
To fix this, simply separate "Comment" from "went" with a space or a new line.

I think with "<" symbols it must have been a similar issue.
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Thu Mar 12, 2015 7:43 am

To fix this, simply separate "Comment" from "went" with a space or a new line.


Ironically, that is what I was attempting to do, but CN did not show me this note in the find, so I did not know about it:
viewtopic.php?f=6&t=1982

I have fixed it now though.

Chris
User avatar
CintaNotes Developer
Site Admin
Posts: 4748
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby CintaNotes Developer » Sun Mar 15, 2015 4:43 pm

Good thing there's also "search inside words" ;)
Alex
User avatar
usbpoweredfridge
Posts: 407
Joined: Fri Jan 17, 2014 11:08 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby usbpoweredfridge » Mon Mar 16, 2015 2:13 pm

Yes, my mistake was thinking that this was the default for CN (ie it would find the word anywhere in the note, not just if the line started with the word).

Chris
User avatar
CintaNotes Developer
Site Admin
Posts: 4748
Joined: Fri Dec 12, 2008 4:45 pm
Contact:

Re: Search not Finding Characters that are in a Note

Postby CintaNotes Developer » Tue Mar 17, 2015 11:34 am

It's not the default because it incurs extra performance penalty (can't use the full text index).
Alex

Return to “Bug Reports”